Dashboard Timeouts
Incident Report for Expedited Security
Resolved
This incident has been resolved. To check if you can access your WAF dashboard correctly now, click on the Expedited WAF or Expedited CDN add-on in your Heroku Application's resources tab.

If you have any further issues please report them to support@expeditedsecurity

We apologize for the inconvenience that this has caused and are taking steps to modify the underlying procedures and checks that led to the dashboard control plane becoming out of sync with the larger Edge Network.
Posted Jul 11, 2022 - 23:54 UTC
Update
We have identified the source of the issue causing some accounts to error after logging in via SSO linking from their Heroku dashboards.

Throughout this outage, the external WAF interface has continued to protect all sites.
Posted Jul 11, 2022 - 21:05 UTC
Update
We are continuing to investigate this issue.
Posted Jul 10, 2022 - 01:22 UTC
Investigating
A small number of accounts are experiencing timeout errors after SSO from their Heroku applications.

We have traced the cause to an edge case in how accounts are provisioned and are actively working on a solution.
Posted Jul 10, 2022 - 01:22 UTC
This incident affected: Expedited WAF Management Dashboard.